My TV only shows a black screen or “No Signal” when I power on the ScreenBeam Mini 2

Follow

Comments

72 comments

  • lidiya

    That is my problem at the moment. It was working fine untill two days ago. Yesterday when I turned it on it started showing black display or something "no signal" I tried to turn it off and on again but nothing changed. It still does not work. What should I do next?

    0
    Comment actions Permalink
  • Theresa Stiefken

    I'm having exactly the same problem as lidiya

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Lidiya,
    Please check your e-mail as I have reached out to you regarding this issue. Please make sure to check your "spam" folder if the email does not show up in your inbox.
    Thank you

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Theresa,
    Please check your e-mail as I have reached out to you regarding this issue as well. Please make sure to check your "spam" folder if the email does not show up in your inbox.
    Thank you

    0
    Comment actions Permalink
  • Ruby Tallabas

    I'm having the same problem, what can I do to make it work?

    0
    Comment actions Permalink
  • Clarissa Johnson

    I unplug mine to move to a different tv and now having 4he same issues, I've tried resetting and unplugging it. Please help

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Clarissa,
    Please check your e-mail an Actiontec technician has responded to your request. If the e-mail does not appear in your inbox, please check any "Spam" or "junk" folders in your email.
    Thank you

    0
    Comment actions Permalink
  • Nicholas Harjo

    Same here, and it was just working a few hours ago

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Nicholas,

    Please check your email for correspondence from an Actiontec representative. Thank you.

    0
    Comment actions Permalink
  • Kelly B

    This is exactly my problem. It worked so great for me for so long. Can anybody help me out.

    0
    Comment actions Permalink
  • Scott Kalin

    I am having the exact same problem. Worked fine, today i turn it on and nothing. Just blinks "actiontec creative solutions for a digital life" at me.

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Scott,
    Please check your email, I have opened a support ticket to help assist with the issue that is occurring.
    Thank you

    0
    Comment actions Permalink
  • William Forrest

    Mine is doing the same thing, anyone know how to fix it?

    0
    Comment actions Permalink
  • Yanira Solivan

    Hi,
    My tv only show " No signal".

    Please, help!!!!

    0
    Comment actions Permalink
  • Joe Tamosaitis

    William,
    Please check your email, I have opened a support ticket to help assist with the issue that you are experiencing. If needed please check your "spam" folder for the email.
    Thank you

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Yanira,
    Please check your email as I have responded to you support request.
    Thank you

    0
    Comment actions Permalink
  • ioannis

    I have a black screen and it just flashes the brand actiontec. plz help needed asap i use it for my job.

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Ioannis,
    Please check your email as I have responded to your request.
    Please make sure to check any "spam" folders if it does not show in your inbox.
    Thank you

    0
    Comment actions Permalink
  • Albert reed

    mine is doing the same thing!! Any help would be great!!

    0
    Comment actions Permalink
  • Albert reed

    mine is doing the same thing!! Any help would be great!!

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Albert,
    Please check your email an Actiontec representative has responded to your request/issue.
    Thank you

    0
    Comment actions Permalink
  • Jonnika W

    Same problem I'm having anyone know how to fix this?

    0
    Comment actions Permalink
  • __*~~*__

    I need help my tv only shows a black screen when I plug in my streambeam mini 2 it says actiontec creative solutions for the digital life it says it over and over again I need help I just purchase this item last week please reply

    0
    Comment actions Permalink
  • __*~~*__

    Hello???

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Hello,
    Sorry for the inconvenience you are experiencing at the moment.
    If the steps above have not resolved the issue or the ScreenBeam receiver will not reset the receiver would be considered defective. Under Actiontec's hardware warranty, the device can be replaced if within the one year from the original purchase date period.
    Please create a request using the "submit a request button at the top" and provide the following information to expedite the process.
    First Name
    Last Name
    Phone Number
    Email Address
    Physical Shipping Address (No PO/APO Boxes)
    City
    State
    Country
    Postal Code
    Date & Place of Purchase
    Serial Number (Off ScreenBeam receiver sticker)
    A brief description of the issue occurring.

    Thank you,
    Joe T.

    0
    Comment actions Permalink
  • Diana

    I connected my screenbeam mini 2 to my mom's smart tv one time and now I tried to connect it to my tv again and it doesn't work anymore. It just shows a black screen. How can I fix this problem need some help?

    0
    Comment actions Permalink
  • Shaunn Beasley

    My screenbeam mini 2 has been working perfectly up until now. My tv doesn't even recognize that it's there anymore, i just get a no signal from my tv....HELP!

    0
    Comment actions Permalink
  • Xxbrandonxx1987

    I'm having the same issue. It was just working an hour ago

    0
    Comment actions Permalink
  • Nicolas Ugarte

    Hi, am having the same issue. For months my sb mini 2 was working perfectly. But now, i can't connect, my tv is black and its like is reseting all the time. Please help

    0
    Comment actions Permalink
  • Joe Tamosaitis

    Nicolas,
    Please open a support ticket and provide the information requested.
    If the steps above have not resolved the issue or the ScreenBeam receiver will not reset the receiver would be considered defective. Under Actiontec's hardware warranty, the device can be replaced if within the one year from the original purchase date period.
    Please create a request using the "submit a request button at the top" and provide the following information to expedite the process.
    First Name
    Last Name
    Phone Number
    Email Address
    Physical Shipping Address (No PO/APO Boxes)
    City
    State
    Country
    Postal Code
    Date & Place of Purchase
    Serial Number (Off ScreenBeam receiver sticker)
    A brief description of the issue occurring.

    0
    Comment actions Permalink

Please sign in to leave a comment.