While trying to connect I receive the message “Oops, Something Went Wrong” or “Unable To Connect”, what should I do?

Follow

Comments

15 comments

  • Klaus-Dieter Sohn

    Nothing helps, very annoying

  • Joe T.

    Klaus-Dieter, please check for updates on your support ticket so that we may hopefully provide a quick resolution to this issue. Thank you.

  • Michael Miles

    I have tried all these steps, and nothing works. Windows 10 PC. I can see the "Screen beam" on my tv, and my pc sees its name. I put in the number and it wont connect. I have shutdown my wireless and tried it without success.

  • MickMeck

    I also have tried these steps. Why don't we all get to see the solution so we can learn? Or is there no solution?

  • Joe T.

    Mick,
    Please see the support ticket you submitted. The issue you submitted where the "cannot connect" message is displayed instantly, appears to be security related and the above steps would not apply.
    Thank you

  • Rich Wilson

    Sent an email, hopefully I can resolve. Had no problems when I first got ScreenBeam and no problems connecting with Android but keep getting the famous "couldn't connect" error message. Windows 10 laptop also tells me there is a problem connecting to a device. Anybody???

  • jerry renner

    I have tried every thing it still says Oops, Something Went Wrong my phone will connect but computer will not

  • Joe T.

    Hello Jerry,
    What operating system is on the PC? You may need to verify that the wireless adapter driver and/or display adapter driver(s) are up to date on the PC. If you would like assistance in checking or verifying the drivers on the PC please submit a support ticket at the top of the page.
    Thank you,
    Joe

  • Rich Wilson

    Have same problems as everyone is describing. What is odd is that it did work when I got it over a year ago.
    Tech support has been beyond helpful. I agree that it may be Intel/Microsoft issues. Intel no longer supports Widi/Miracast. Hoping that eventually someone will figure this out. I promise to share any and all information, including a solution once there is one.

  • Rich Wilson

    Hi folks,

    Reached out to Microsoft. They are as helpless as can be expected. I will give them credit for NOT asking me to pay one of their techs to try and solve problem.
    This problem has been going on for a while and Microsoft refuses to address it. Want the run-around? Try their forums.

    Hopefully one day soon some body will come up with a fix. Wish it could be me though. If I come across something I will post for all to know.

    Rich

  • Jane Unger

    I can't believe this issue is still going on. I just got the recommendation from BestBuy yesterday to buy the StreemBeam Mini 2...only to have these same issues. I spent 4 hours trying to figure this out and waiting to hear back from tech support. I have little confidence that this will be resolved. I think I'm going to have to hard wire and not mess with this device.

  • Mark A. Rawlins

    Like the previous comments. I have attempted the suggested steps over and over, and still get the same results. Oh wow! I must be insane. Doing the same thing over and over again and expecting different results. That's a first for me.

  • James Ising

    In the last point, before you reboot use program like CCleaner to remove all traces of program, reboot re-install. May help

    James

  • Kimberly Everett

    Just unplug and turn it on a different device in another room. Come back to original monitor and it will automatically reset itself. You got to trick to reset it. Real talk.

  • Kimberly Everett

    Don't start playing with stuff let it think on its own.

Please sign in to leave a comment.