Follow

I'm seeing choppy and/or there are brief pauses during playing Internet video on my Miracast device. How can I resolve this?

This can occur if the wireless signal between the source device and the ScreenBeam receiver is poor or is too crowded. You can prevent video playback problems in the following ways: 

  • Move the source device closer to the ScreenBeam receiver to improve wireless signal strength.
  • Remove unused portable WiFi devices from between the source device and receiver.
  • Disconnect unused devices from the WiFi network.
  • If the video is being viewed in a web browser, clear the web browser's history and restart the browser.  You can also try a different web browser.
  • If the source device is connected to a WiFi network, change the channel used by the WiFi network.  The wireless display connection to your ScreenBeam receiver will use this same channel.  Consult the user guide for your WiFi router or access point for information on how to change this setting.
  • If the source device is a Windows laptop/tablet, ensure the latest drivers for the Display and Wireless Network adapters on the source device are installed.
Print Friendly and PDF
Have more questions? Submit a request

Comments

  • Avatar
    Dharp4

    I have the same problem when connecting from my laptop.  Video is fine on the laptop and when I plug it into my TV via HDMI but jittery and dropping frames via screen beam pro.  It has been this way since I purchased it months ago and I keep all my drivers, firmware, and software up to date.  No improvement yet.  All of my other wireless and streaming devices work just fine in the same room and on the same TV.